月別アーカイブ: 2010年7月

Xampp入れ直しにハマる

http://www.apachefriends.org/jp/xampp-windows.html
http://sourceforge.net/projects/xamppaddon
今入ってるXamppが古いので、最近のを入れようとして失敗。
最初色気を出して今のXampp1.6.3を残しつつ最新のXampp1.7.3を別の場所に入れようとしたが、インストールはできるものの、apacheがちよっと立ち上がってすぐに落ちてしまう。
Xampp1.7.3を何度もアンインストール・インストール繰り返して、いろいろ試行錯誤したがうまく行かない。
あきらめてXampp1.6.3をアンインストールして、同じドライブにXampp1.7.3を入れてみるが、やはりダメ。
apacheのlogs/error.logを見ると
[crit] (22)Invalid argument: Parent: Failed to create the child process.
みたいなエラーが出てるみたい。
Skypeなどでポートが使われてたりすると出ることが多いエラーらしいけど、ポートチェックしてもFreeになってる。
更にあきらめてXampp1.7.3をアンインストールして、以前のXampp1.6.3を入れなおしたが、apacheが立ち上がりもしなくなってしまった。
もうあきらめて元に戻そうと、作業前に作っておいた復元ポイントで復元。
再起動後、「復元は未完了 コンピュータを次の時点まで復元できません: この復元は完了していません。」みたいなメッセージが出て復元失敗。
とりあえずできることをやってみようと、ダメ元でレジストリを確認しバックアップしつつ1個ずつ削除したり、使ってないソフトをいくつか削除したりしてみる。
ちょっと前の、自動でインストールできる1.7.1を入れてみる。
インストール成功。apacheもちゃんと動く。
activeperlをxamppのperlフォルダにインストール。
以前usrと関連付けたジャンクションがそのまま有効になってて、perlをテストしてみるとusr/bin/perlでちゃんと動く。
コマンドプロンプトからMTに必要な環境を入れる
ppm install http://cpan.uwinnipeg.ca/PPMPackages/10xx/DBD-mysql.ppd
ppm install http://cpan.uwinnipeg.ca/PPMPackages/10xx/Crypt-DSA.ppd
ppm install http://www.bribes.org/perl/ppm/Image-Magick.ppd
ppm install Mail-Sendmail
とりあえずxamppアンインストール時に退避させてたhtdocsとmysqlを上書きで戻してみる。
ちゃんと表示される。
以前テストしたMT4は特に問題なく動いてるみたいだ。
ImageMagickをインストールしても認識されない。
ぐぐってみる。
Movable Type 5で「サーバーに Image::Magickか、Image::Magickの動作に必要な他のモジュールがインストールされていません。」となる事象について
http://www.koikikukan.com/archives/2010/07/09-035555.php
http://www.h-fj.com/blog/archives/2009/05/02-094903.php
http://kiyoeri.gotdns.com:8089/drupal6.8/?q=node/103
ImageMagickをインストールしたフォルダにパスをとおしてみたりするけど、うまく行かない。
やり直してみることにする。
もう一度、ImageMagickをアンインストール(フォルダ内のunins000.exeで)して、
http://www.koikikukan.com/archives/2009/04/12-012345.php
慎重にPerlのバージョンに合ったImageMagickをダウンロードし、
こちらに書かれてる通り、Xamppフォルダにインストールしてみる。
http://www.dakiny.com/archives/movable-type/movable_type_4xampp_for_windowsimagemagick/
(一応ImageMagickに合うPerlmagickをインストールするにチェックした)
一応、一度再起動してみてからmt-check.cgiを動かしてみたら、ちゃんと認識されていた。
結局、何が悪かったのか、何が良かったのか釈然としないことが多かったが、動くようになったので良しとしよう。

ThunderbirdアドオンQuicktext

Thunderbird3.1にバージョンアップする際、アドオンのQuicktextが対応していないため無効と言われる
Quicktextの新しいバージョンはないが、現在と同じバージョンを作者サイトより落としてインストールしなおすと、3.1に対応してるらしく、Thunderbird3.1にバージョンアップできる